es.OpenEstate.org

Soluciones abiertas para el Sector Inmobiliario

ImmoTool 0.9.22

En las últimas semanas hemos realizado de nuevo muchas correcciones detalladas en el ImmoTool. Además hemos decidido aumentar los requisitos minimos del programa de Java5 a Java6.

Aumento de los requisitos minimos

Con la primera publicación del ImmoTool ya era de esperar el fin del Java5. Desde Octubre 2009 ya no se proporcionan actualizaciones para Java5 (véa Publicación de Oracle). Mientras nos fue posible, aseguramos la compatibiliad del ImmoTool con Java5.

Un importante Componente-”Open Source” dentro del ImmoTool, y que utilizamos en el Procesamiento-XML, es JAXB. Desde la publicación de JAXB 2.2.5 ya no se puede utilizar dicha biblioteca con Java5 (véa Notificación de un JAXB-Programador). Llegados a éste punto estabamos ante el problema de seguir trabajando siempre con la última versión de JAXB compatible con Java5 o aumentar los requesitos minimos del ImmoTool al Java6. Los procesos XML son la parte fundamental del ImmoTool, por ello no queremos renunciar a las constantes actualizaciones del Projecto-JAXB. Es por ésta razón por la que hemos decidio de no seguir apoyando la obsoleta versión de Java5 con el ImmoTool.

Ésta decisión nos trae al final más ventajas que desventajas:

  • seguimos benficiados de las actualizaciones y correcciones del Projecto-JAXB. Además podiamos actualizar diversas otras bibliotécas como SwingX y BSAF. Otras bibliotecas como Swing-Worker y Swing-Layout hemos podido quitar, ya que solo las usamos por la compatibilidad del Java5.
  • Las mejoras de la Plataforma-Java6 nos da las herramientas necesarias para conseguir mejores resultados para los usuarios del ImmoTool.
  • Renunciando  al Java5 hemos ganado más tiempo, que dedicamos ahora a la Plataforma más usada por la mayoria de los usuarios.

Asumimos que ningún usuario debería encontrarse afectado por dicho cambio. Los que trabajen con un equipo mas o menos actualizado, debería seguir utilizando el ImmoTool sin problema ninguno – es posible que tengan que instalar el Java6 o Java7 de nuevo.

¿Como puedo obtener la versión actual?

  • Si ya tiene instalado el ImmoTool debe usar la función interna de actualización del programa.
  • Los paquetes de instalación han sido actualizados con la nueva versión y estan disponibles en la zona de descarga. Encontrará las versiones más antiguas en la zona del usuario.
  • Si tiene problemas con la configuración / instalación puede obtener más ayuda (en inglés) en la Guía de instalación.